Art Blocks available to mint showing duplicates
Incident Report for NFTX
Resolved
When there are multiple vaults with the same contract we are only doing the lookup once. This is saving an additional 7 requests to the graph and is now showing the correct number of art blocks.
Posted Jul 22, 2021 - 09:00 UTC
Identified
To show the available NFTs you have for minting we take all the current vault NFT contract addresses and use them to match against and NFTs you have in your wallet. Currently there are 8 Art Block vaults, but they all share the same Contract address (we separate what is eligible in those vaults through a range).

We were then querying the wallet 8 times to find art blocks, and not making the array unique (hence why it showed that you had 8x the number of artblock NFTs available to mint.
Posted Jul 22, 2021 - 08:59 UTC
Investigating
We are seeing an issue where Art Block vaults are listing more NFTs available to mint than are in your wallet. When viewing the vault mint screen we are seeing multiple versions of the same NFT.

A refresh of the page fixes this. This is a UI issue and doesn't impact the minting/redeeming.

Further updates to come.
Posted Jul 21, 2021 - 22:21 UTC
This incident affected: NFTX App.