CryptoKitties Revoke Mint Request failing
Incident Report for NFTX
Resolved
Contract has gone through aragon and the changes are now live, revokeMinting is now available for the Kitty contract.
Posted Jun 08, 2021 - 15:51 UTC
Update
The contract update has been made and is going through the Aragon process.

Vote 135: Set new contract implementation (https://etherscan.io/address/0x0C68F11ad08EF6a02C4224fA6D6585D8b3102a26#code) to fix bug in revokeRequest function when handling cryptokitty vaults.
Posted Jun 07, 2021 - 09:38 UTC
Identified
To have your Kitty approved to go into the vault a Request Mint is required. Once submitted, the team check to ensure that your Kitty is a Generation 0 for the Kitty-gen-0 vault, and that it is Generation 0 and Fast recovery on the Kitty-Gen-0-F vault.

If the Kitty belongs, the request mint will be approved and you will be issued your token.

If the Kitty is inelligible it will not be approved. The only way to get your Kitty back at that point is to call the Revoke Mint Request.

At the moment this call against the Kitty contract is failing as the CryptoKitties contract does not follow the ERC721 standard contract. This issue has been found and a patch is being added. Once released this ticket will be updated to Monitoring and we a note added to discord.
Posted Jun 06, 2021 - 13:59 UTC
This incident affected: NFTX App.