Metadata API Down
Incident Report for NFTX
Resolved
The endpoint is not longer returning 429 requests and we've logged a ticket with OpenSea to investigate further.
Posted Jul 27, 2021 - 19:30 UTC
Investigating
The Metadata API are receiving timeout requests to OpenSea so none of the images are loading for NFTs on the site.

We are currently looking into the issue.
Posted Jul 27, 2021 - 19:23 UTC
This incident affected: NFTX App.