V2 Kitty Vault Redemptions
Incident Report for NFTX
Resolved
The updates to the contact have now been pushed and the Kitty redemption is working as expected.
Posted Jul 14, 2021 - 06:47 UTC
Update
The issue has been patched on the Kitty contract and the vote is on Aragon. We expect this to pass and enacted in the next 24 hours
Posted Jul 13, 2021 - 07:47 UTC
Identified
There is an issue with redeeming Kitties from the V2 KITTY vault.

The standard 721 uses `transferFrom` however the Kitty contract requeries the use of `transfer`. This is causing the preflight checks to prompt the wallet approval (metamask in most cases) to fail.

You can still mint your Crypto Kitties into the V2 vault and receive your tokens, provide liquidity, and stake, however the redeeming is offline until the contract can be updated.

Further details on the timing of the changes will be provided.
Posted Jul 12, 2021 - 19:34 UTC
This incident affected: NFTX App.